Results 1 to 2 of 2

Thread: App permissions work while testing but not after deployment to cloud server

  1. #1
    Junior Member
    Join Date
    Oct 2018
    Posts
    1

    App permissions work while testing but not after deployment to cloud server

    While previewing my app in browser view on my PC all static user permissions work as expected for each logged on user. The problem is when the app is deployed to the cloud server every user has full access to all elements. The system database containing user accounts and permissions and the app itself are up to date on the server so I have been racking my brain as to why there seems to be a difference between viewing the app in localhost vs the actual server. Any help or suggestions with this would be much appreciated.

  2. #2
    Lianja Development Team barrymavin's Avatar
    Join Date
    Feb 2012
    Location
    UK, USA, Thailand
    Posts
    5,962
    Depending on what browser you use, you can inspect and view the headers returned when you login. This will help you see what roles the logged in user has.

    If it works on your development machine it will work on a remote cloud server if you have deployed the system database.
    Principal developer of Lianja, Recital and other products

    Follow me on:

    Twitter: http://twitter.com/lianjaInc
    Facebook: http://www.facebook.com/LianjaInc
    LinkedIn: http://www.linkedin.com/in/barrymavin

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Journey into the Cloud
Join us