Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Email issue using mailopen()

  1. #1
    Senior Member
    Join Date
    Jul 2013
    Location
    Ontario, Canada
    Posts
    658

    Email issue using mailopen()

    Hello,

    I am having an issue with mailopen() while trying to send an email from Lianja.
    I am using the following format:
    Code:
    m_open = mailopen("smtp.server.com","username","password","SMTP")
    if not m_open
       dialog box mailerror()
    else
       // process email.
    endif
    I keep getting the error "211 2.0.0 Bye" returned.

    I have gone into my outlook account and verified my settings are correct.
    I have even used the username and password to log into web mail.

    I believe I only have 1 firewall - Windows firewall.
    I tried turning it off although it didn't make any difference.

    Any suggestions on how I can get this to work so I can send an email?

    Thanks,
    Cory
    Last edited by CGibson; 2015-02-03 at 09:24.

  2. #2
    Lianja Team yvonne.milne's Avatar
    Join Date
    Feb 2012
    Location
    Berkshire, UK
    Posts
    1,662
    Hi Cory,

    Is it an SMTP server or ESMTP?
    If SMTP, is it on port 25?

    Regards,

    Yvonne

  3. #3
    Senior Member
    Join Date
    Jul 2013
    Location
    Ontario, Canada
    Posts
    658
    Hi Yvonne,

    I'm assuming SMTP although I have no idea what the difference is.
    How do I verify the port?

    Cory

  4. #4
    Senior Member
    Join Date
    Jul 2013
    Location
    Ontario, Canada
    Posts
    658
    Testing with telnet "telnet smtp.xxx.ca 25", the response is "200 smtp1.xxx.ca ESMTP"

    Cory

  5. #5
    Lianja Team davefoss's Avatar
    Join Date
    Feb 2012
    Posts
    111
    Hi Cory,

    The settings in Outlook should include the port.

    You can also use telnet to test SMTP:

    https://technet.microsoft.com/en-us/...chg.65%29.aspx

  6. #6
    Lianja Team davefoss's Avatar
    Join Date
    Feb 2012
    Posts
    111
    Looks like you've got an ESMTP server then. We just added support for ESMTP so you should be able to just replace SMTP with ESMTP.

  7. #7
    Senior Member
    Join Date
    Jul 2013
    Location
    Ontario, Canada
    Posts
    658
    Hi Dave,

    Outlook does show SMTP using port 25

    Cory

  8. #8
    Senior Member
    Join Date
    Jul 2013
    Location
    Ontario, Canada
    Posts
    658
    Hi Dave,

    Changing the mailopen to ESMTP didn't seem to make a difference (using v1.3).

    Cory

  9. #9
    Lianja Team davefoss's Avatar
    Join Date
    Feb 2012
    Posts
    111
    Just double checking the doc - you may also have to BASE64_ENCODE() the user/pass:

    http://www.lianja.com/doc/index.php/MAILOPEN%28%29

  10. #10
    Lianja Team davefoss's Avatar
    Join Date
    Feb 2012
    Posts
    111
    Sorry, I seem to always be a step behind! Looks like you're back to testing with telnet using the link I posted above.

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Journey into the Cloud
Join us