Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Moving files to another computer

  1. #1
    Senior Member
    Join Date
    Jul 2013
    Location
    Ontario, Canada
    Posts
    658

    Moving files to another computer

    Hello,

    I want to move my files to another computer. Some things seem to work while others do not.

    On the new machine, I installed Lianja app builder and copied the associated app files from apps/app_name and data/app_name.
    Are there any other files I should have copied?

    The app works fine on the first computer but crashes on the new computer.
    I'm not positive, although there seems to be an issue with the virtual table.

    A visual C++ Runtime Library error appears:
    Runtime Error!

    Program: C:\Lianja\bin\lianja.exe

    This application has requested the Runtime to terminate it in an unusual way.
    In addition, the debug.txt file has the following:
    File E:\recital\c\source\rct_use.c at line 3115 virtualtable_use() table=C:\Lianja\data\bantam_stats\vt_roster.dbf alias=VT_ROSTER fields= where= orderby= select= tally=0
    File E:\recital\c\source\rct_use.c at line 3195 cmdbuf=USE 'vt_roster.dbf' IN 3 CONNSTR "local@@basetable=@@primarykey=@@properties=" alias "VT_ROSTER" as select * from roster where 1=0
    Any help would be greatly appreciated.

    Cory

  2. #2
    Senior Member
    Join Date
    Jul 2013
    Location
    Ontario, Canada
    Posts
    658
    Here's what I did.
    On the windows 7 machine, I installed xp mode and tried to use Lianja and the files in that environment.

    That didn't work.

    Doing the same thing on another windows 7 machine, seems to have worked. No crashes or errors appeared.

    Cory

  3. #3
    Lianja Team davefoss's Avatar
    Join Date
    Feb 2012
    Posts
    111
    Quote Originally Posted by CGibson View Post
    Hello,

    I want to move my files to another computer. Some things seem to work while others do not.

    On the new machine, I installed Lianja app builder and copied the associated app files from apps/app_name and data/app_name.
    Are there any other files I should have copied?

    The app works fine on the first computer but crashes on the new computer.
    I'm not positive, although there seems to be an issue with the virtual table.

    A visual C++ Runtime Library error appears:


    In addition, the debug.txt file has the following:


    Any help would be greatly appreciated.

    Cory

    Hi Cory,

    This is a shot in the dark here, but try deleting any .dbo files from your app's directory and the ./library/ directory and see if that changes the behavior.

  4. #4
    Senior Member
    Join Date
    Jul 2013
    Location
    Ontario, Canada
    Posts
    658
    Hi Dave,

    I tried your suggestions and that didn't seem to make much of a difference.

    Quote Originally Posted by CGibson View Post
    Doing the same thing on another windows 7 machine, seems to have worked. No crashes or errors appeared.
    I should point out that the second windows 7 machine had Lianja installed on the actual machine, not the virtual machine.

    Cory

  5. #5
    Lianja Development Team barrymavin's Avatar
    Join Date
    Feb 2012
    Location
    UK, USA, Thailand
    Posts
    6,081
    You need to copy your app, library and data or package it as a .lpk file and import it.
    Principal developer of Lianja, Recital and other products

    Follow me on:

    Twitter: http://twitter.com/lianjaInc
    Facebook: http://www.facebook.com/LianjaInc
    LinkedIn: http://www.linkedin.com/in/barrymavin

  6. #6
    Lianja Development Team barrymavin's Avatar
    Join Date
    Feb 2012
    Location
    UK, USA, Thailand
    Posts
    6,081
    Oh and just to mention, when I prepare the distros i copy apps, data and library directory between windows, linux and mac and thats what ships.
    Principal developer of Lianja, Recital and other products

    Follow me on:

    Twitter: http://twitter.com/lianjaInc
    Facebook: http://www.facebook.com/LianjaInc
    LinkedIn: http://www.linkedin.com/in/barrymavin

  7. #7
    Senior Member
    Join Date
    Jul 2013
    Location
    Ontario, Canada
    Posts
    658
    Hi Barry,

    I tried both methods and still had the same issue.
    I can only assume that something gets blocked by Windows 7 XP mode.

    Cory

  8. #8
    Lianja Team davefoss's Avatar
    Join Date
    Feb 2012
    Posts
    111
    Quote Originally Posted by CGibson View Post
    Hi Barry,

    I tried both methods and still had the same issue.
    I can only assume that something gets blocked by Windows 7 XP mode.

    Cory
    Hi Cory,

    There was a known issue with virtual tables under XP, but as far as I know it has been resolved in the latest release. What release are you running?

  9. #9
    Senior Member
    Join Date
    Jul 2013
    Location
    Ontario, Canada
    Posts
    658
    Hi Dave,

    I still think it's an issue with Windows 7 XP Mode (SP3 and all updates are current).
    I am using RC10 - Oct 28 9:57.

    Cory

  10. #10
    Lianja Team yvonne.milne's Avatar
    Join Date
    Feb 2012
    Location
    Berkshire, UK
    Posts
    1,471
    Hi Cory,

    Do the lianjademo and example_virtualtables Apps run OK on the XP Mode machine?

    Have you ever installed a version of the App Builder or App Center on the XP Mode machine before?

    Regards,

    Yvonne

Page 1 of 2 12 LastLast

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Journey into the Cloud
Join us