View Full Version : Liveview server not running

2019-09-20, 13:46
Hi guys

We need to start testing our mobile tablet app - on android to begin with.

We will obviousy need to install all the certificates etc eventually for a proper build but for now just tryng to use the Liveview.

Have read the aricles on using liveview and it looks simple but have tried both tablet and phone Liveview for Android but we always get :

"Android tablet Liveview server failed to start" when we press the Liveview button (ios liveview server doesn't start either).

We have installed on default install directories. Running on development laptop. No firewall.

Are there any tricks to get Liveview going?

Thanks in advance


2019-09-20, 15:31
All details are provided at:

2019-09-21, 18:06
Thanks Barry

Installing 5.0RC58 solved the Liveview server issue.

Got it running on android tablet and obviously deployed the data as usual to cloud server but when testing on tablet there is complaint that the "database has not been deployed". Is there a separate copy of the data required for the tablet testing using liveview?



2019-09-22, 10:09
Double checked that the data - database and tables have been deployed to C:\Lianja\cloudserver\tenants\public\ but we are still getting "database has not been deployed" error on the tablet.

UI seems to come up fine.

Anyone else had a similar experience?



2019-09-22, 12:29
Hi Simon,

Please Log a ticket so this can be investigated. It's probably related to the IP address specified.

2019-09-22, 13:07
Looking at our code, that error can be shown if an initialization error occurs when the phonegap app is loaded. The only way to determine what it is would be to build a phonegap android app in debug mode and using the remote debugger connect to it and inspect the javascript console.

Have you tried running this in "Preview live in browser" first to verify that it works?