PDA

View Full Version : Tablet_index.html not generated



rcahoon
2016-11-26, 12:28
I can't seem to get my Lianja to generate a tablet_index.html.

I opened my deployment folder: D:\lianja\cloudserver\tenants\public\wwwroot\apps. The folder is empty.

I opened example_webapp1 and checked that the tablet UI Presentation Rule is ticked and that the directory and deployment directory settings were correct.
I saved the app. Message: App Saved
I clicked the Tablet App View and the app is displayed in the Tablet App View and works as expected.
I clicked the Tablet App View Deploy button. Message: example_webapp1 generated in debug mode and the folder example_webapp1 is created in the deployment folder.
On checking the folder there is an index.html but no tablet_index.html.

When I try to load the app on a tablet, I get a message saying tablet_index.html not found.

What am I doing wrong?

Cheers,

Rob C

HankFay
2016-11-26, 21:24
Hi Rob,

run the Tablet View. Right click the results screen and click Inspect. See if there is a red x in a circle, bottom right of Inspector. If there is, that means there's an error. Click it and it will tell you the location of the error, showing you where in it happened.

If not, beats me. :)

Hank

rcahoon
2016-11-27, 05:11
Hank,

I've done as you suggested and no errors are displayed. There are 185 CSS related warnings but no errors. Clicking deploy appears to re-generate the index.html but won't create a tablet_index.html.

I will uninstall and reinstall Lianja using the standard installation folders and see if that make any difference.

Thanks,

Rob C

rcahoon
2016-11-27, 09:51
I've uninstalled everything and then re-installed clean using default settings and folders. I've deployed example_webapp1 and it's working perfectly in the Web View, Web Preview, local and remote browsers.

However, I still cannot generate a tablet_index.html and I still get an error saying "tablet_index.html" not found when accessed from a Galaxy tablet. I checked the inspector int eh Web Tablet View and there are no errors.

Rob C

yvonne.milne
2016-11-28, 04:56
Hi Rob,

I've submitted a ticket for this. 'Deploy' in the Tablet App View and Phone App View is naming the generated file 'index.html' instead of 'tablet_index.html' and 'phone_index.html'.

If you click the 'Deploy' in the Tablet App View and rename the resulting 'index.html' file 'tablet_index.html' this will give you the correct file to test on your tablet. Sorry for the inconvenience.

Regards,

Yvonne

rcahoon
2016-12-02, 17:17
Yvonne,

I understand. I assume this means that when deploying from tablet/phone views the existing web client index.html will be over-written so you'll always need to re-deploy from the web client after deploying and renaming from the tablet and/or phone views. Otherwise your web clients end up accessing the tablet/phone views.

Thanks,

Rob C

barrymavin
2016-12-02, 22:54
Hi Rob,

until it is fixed yes.