View Full Version : APP center fails to identify Usernames and passwords

2016-10-17, 11:20
Dear All,
After upgrading to Version 3 I had a lot of issues to deploy the application updated from 2 to 3. I discussed with Yvonne who assisted a lot but I couldn't deploy the application using the Intaller. the only way was to install the APP center and replace the \bin directory with the content of \bin directory of my installed App builder.
However, I discovered that only the admin user is recognized to access the application form the app center, even when I use --username and --password switches in the shortcut.
Users and permission exist in the system database, I can access to them from the APP buider. I redeployed the system database but still more the user can't be authenticated, apart from the default admin.
I lost and spent more time on deploying Lianja app on Windows 2008 R2 infrastructure, I wonder if there is not any hiden incompatibility.
Can I have some tips to fix the issue?
I have all users using admin role for the application!!


2016-10-17, 18:25
Hi Esperant,

I built an NSIS installed for an App Center application and once I got rid of my own bugs <s> it has worked fine.

Note that you do have to make sure your app isn't in use in any way before updating with the installer.


2016-10-18, 03:34
For some strange reason the way you are installing has permissions problems. You have been dealing directly with the development team via tickets to try and resolve this.

I am not aware of anyone else having this issue.

You need to explain how you are installing the app center on the client PCs and how you install the apps for that.

Needless to say this is not a standard install or it would just work out of the box.

Yvonne has already identified that your issue is permissions related. If you are copying the installed app builder bin directory and it works then the user that copies that may have the required permissions but when you install they may not.

Where is the app center being installed, on what drive?

Are you installing on a shared drive or the system drive?

You redeployed the system database to where?

When you run the app center exit it then look in the log directory and attach it to a ticket. That tells us what your environment is that you are trying to run in.

Have you tried opening a command window then cd to the lianja\bin directory and type .\lianjaruntime.exe

That may shed some light on the issue you are having as you may have a duplicate dll in your path which is the wrong version.

You can delete the system database on your target directory and copy the development system database to be sure that it is being copied properly. It cannot be overwritten if its open in a client PC.

if you want to verify that you are not missing any dlls download dependency walker and open lianjaruntime.exe