PDA

View Full Version : User authentication issues



jmartyr
2016-01-28, 19:50
Hi all,

I've deployed a quick draft of my mobile app to test ui elements but when I run the app on my phone I can't get past the login screen. An incorrect username/password makes the phone vibrate, a "correct" one just clears the text fields and leaves you on that page. Is there a setting somewhere I need to change to tell the app what to do once authenticated?

I put "correct" in quotes because admin/admin works, but I've changed admin's password in the app builder. Also curiously and perhaps related, the only login that works on my desktop app center is admin/admin, even though that password should be incorrect and I've set up other users.

I've tried turning off "require login" in the app settings but it still starts with the login page.

Any help would be appreciated!

barrymavin
2016-01-28, 20:40
HI Joanna,

Are you running in live view or loading the app onto the phone after building with adobe phonegap build service?

Are you running in a VM or on a bare metal PC?

Have you relaxed your firewall to enable port 8001?

jmartyr
2016-01-28, 22:09
Hi Barry,

I've loaded the app onto my Android phone after building it with Phonegap. The server is on the same machine as the app builder, a bare metal Windows PC.

I couldn't work out how to open a specific port on my firewall so I just turned it off and the same thing still happens.

barrymavin
2016-01-28, 22:28
Hi Joanna,

Have you deployed the database?

Is the cloud server running?

The way this works for testing is...

- Your router allocates IP addresses using DHCP.
- When generating the code for the mobile app Lianja will look at the IP address allocated to your machine and that is how it connects to the cloud server.

Does this still occur when you build one of the example mobile apps?

You need to follow the guide for debugging android and look in the console on your android device to see what errors are occurring.

barrymavin
2016-01-28, 23:18
Hi Joanna,

So just to clarify... Your android device needs to be connected into the same wifi network as your PC when testing like this.

yvonne.milne
2016-01-29, 08:08
Hi Joanna,

Re the users you have created or modified, these need to be deployed to be accessible in the Lianja App Center and Lianja Cloud Server.

http://www.lianja.com/doc/index.php/Users_and_Roles#Deploying_Users_and_Roles

Regards,

Yvonne